Ankündigung

Einklappen
Keine Ankündigung bisher.

ToolsVersion "14.0" bei Rad Studio 10.3 (Delphi) Embarcadero

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • ToolsVersion "14.0" bei Rad Studio 10.3 (Delphi) Embarcadero


    Hallo,

    ich habe mir das Rad-Studio 10.3 herunter geladen und leider kommen beim


    Starten bzw. Kompilieren eines Projektes seltsame Fehlermeldungen, die sich auf die
    Registry beziehen:



    Compilieren von CardPanel.dproj (Debug, Win32)
    MSBuildToolsPath ist für die bei "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSBuild\Too lsVersions\14.0" definierte ToolsVersion "14.0" nicht angegeben, oder der angegebene Wert wird zu einer leeren Zeichenfolge ausgewertet.
    [Fataler Fehler] MSBuildToolsPath ist für die bei "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSBuild\Too lsVersions\14.0" definierte ToolsVersion "14.0" nicht angegeben, oder der angegebene Wert wird zu einer leeren Zeichenfolge ausgewertet.



    Das sind also die seltsamen Fehlermeldungen. Wie kann man dem abhelfen?

    Über eine Antwort von Ihnen bin ich sehr dankbar.


    Das Programm ist die letzten Monate gut gelaufen und nun kommen diese seltamen Fehlermeldungen.

    Liebe Grüße
    Reiner




  • #2
    Hallo!

    Guckst du hier.

    https://community.embarcadero.com/ar...e-toolsversion

    Kommentar


    • #3
      Hallo,

      vielen lieben Dank für Deone Antwort.

      Liebe Grüße
      Reiner

      Kommentar


      • #4
        Hallo, ich bins nochmals Reiner.

        Es geht nochmals um die ToolsVersion "14.0", weswegen Delphi 10.3.2 Rio nicht funktioniert.

        irgendwie werde ich nun doch nicht mit dieser Site von Embarcadero nicht richtig schlau, denn heißt das nun, dass in der Registry der Eintrag unter ToolsVersions überhaupt nicht erscheinen darf ? Das steht aber doch im Widerspruch zu der Fehlermeldung, wonach die ToolsVersion "14.0" nicht angebeben ist. Nach meinem Verständnis müsste sie dann hinzugefügt werden, was aber dann auch nicht funktioniert.
        Hiermit gebe ich eine kurze Auflistung meiner Registry: MSBuild, darunter die Ordner 3.5 und 4.0, dann folgt ToolsVersions mit den Unterordnern 2.0, 3.5. 4.0 und als Unterordner von 4.0 folgt 11.0.
        Was muss ich nun genau in die Registry hineinschreiben ?
        Ich bin regelrecht am Verzweifeln, weil ich das Delphi 10.3.2 Rio dringend brauche.

        Ich wäre Dir überaus dankbar für Deine weitere Hilfe.

        Liebe Grüße
        Reiner

        Kommentar


        • #5
          Hallo,

          vielen Dank für Deine Antwort nd Hinweise. Es hat nun alles geklappt.

          Liebe Grüße
          Reiner

          Kommentar

          Lädt...
          X